New Requirement for WooCommerce 8.2: PHP 7.4+

The details

The minimum PHP version required for WooCommerce was bumped from 7.2 to 7.3 in WooCommerce 7.7 in May 2023. As part of that announcement, we mentioned that during mid 2023, we would bump the PHP requirement for WooCommerce to 7.4. Starting with version 8.2, scheduled for release in October 2023, WooCommerce will require PHP 7.4 or newer to work.

Why this change?

We took this decision for the same reasons that made us decide to bump to PHP 7.3: we are actively working on modernizing the WooCommerce codebase in order to keep it performant, scalable and secure; this includes improving compatibility with the PHP 8.x family, and removing support for old versions is an integral part of these efforts.

A PHP requirement bump announcement isn’t complete without the corresponding version usage graph, so here’s the one for May 2023:

If you compare it with the graph from January, you’ll see that PHP 7.3 is still declining, but it’s even more interesting to see how PHP 8 continues growing.

For completeness, here’s the graph for sites with WooCommerce 7.2 or newer, that is, the sites that got WooCommerce upgraded in the last six months:

We see an even higher presence of PHP 8 and an even lower usage of PHP 7.3. The share of these recently updated sites that use PHP 7.4 or newer is around 97%.

How can I tell if this affects me?

If your server is still on PHP ≤7.3 by the time WooCommerce 8.2 is published, your WooCommerce instance will continue working, but you won’t be able to upgrade past WooCommerce 8.1 (or any 8.1.x maintenance release published afterwards).

What action should I take?

We strongly recommend that you run an up to date and supported version of PHP; that includes PHP 8.0 and newer versions. The latest versions of PHP bring numerous performance improvements and ensure that your site is secure.

6 responses to “New Requirement for WooCommerce 8.2: PHP 7.4+”

  1. Hi @konamiman, is WC officially supporting 8.2 yet? There’s lots of warnings/notices from core.

    1. konamiman Avatar
      konamiman

      Hi Josh. While we have an official policy for the minumum PHP version supported by WooCommerce, that’s not the case for the maximum.

      That said, part of the maintenance work that my team is in charge of for WooCommerce core is ensuring that it works with the newest PHP versions available, so we allocate resources to fix warnings and errors as they come to our knowledge (recent example). Feel free to open issues for incompatibilities that you discover and haven’t been reported yet.

  2. LowlyAdmin Avatar
    LowlyAdmin

    Great news, although 7.4 is already out of security support. I hope there will be a bump of the requirement up to 8.1 soon after. WooCommerce is a great tool for forcing companies/bosses to switch to a newer php version.

    1. konamiman Avatar
      konamiman

      I’d really love to see the PHP version requirement bumping trend for WooCommerce still going on, but I’m afraid this will be the last one in a long time: as the graph shows, the vast majority of installs are on PHP 7.4, so it will take some time until this number decreases significantly.

      But who knows, the technological world is full of surprises! We won’t stop revisiting the usage statistics prediodically anyway.

  3. A while back Woocommerce documented that PHP 7.4 was “strongly recommended” for many versions up through 6.6 (see link: https://woo.com/document/update-php-wordpress/). I’m curious if you will give an updated recommendation, such as strongly recommending PHP 8.1 with a minimum of PHP 7.4?

    1. Great call-out: we’ll take a look at that page. However, it’s worth noting here that a strong recommendation depends not only on WooCommerce’s own degree of compatibility with a given PHP version, but that of WordPress itself.

Leave a Reply

Your email address will not be published. Required fields are marked *