Developer Advisory

Requirements Change for Action Scheduler


In an upcoming release of Action Scheduler, we are planning to raise the minimum WordPress and PHP requirements needed to use the plugin.

The details

As of Action Scheduler 3.2.1 (the current release at time of writing), Action Scheduler requires:

  • PHP 5.3
  • WordPress 4.7

We’ve decided the time is right to make some reasonable adjustments to those requirements, which as of Action Scheduler 3.3.0 will become:

  • PHP 5.6
  • WordPress 5.2

How can I tell if this affects me?

This change impacts any plugins or themes that include Action Scheduler as one of their bundled vendor libraries. It also impacts any sites where Action Scheduler is installed as a standlone plugin. In these cases, before updating Action Scheduler to 3.3.0 or higher, it is important to perform some basic safety checks.

What action should I take?

If you include Action Scheduler as a library of your own theme or plugin, then prior to updating please ensure that:

  • Your own project meets at least the new minimum requirements set by Action Scheduler.
  • If necessary, consider adding safety checks to make sure the installation environment meets those new requirements.

On the other hand, if you maintain a site where Action Scheduler is installed as a standalone plugin, then before you update to 3.4.0 or higher you should:

  • Make sure you are using PHP 5.6 or higher.
  • Make sure WordPress is version 5.2 or higher.

Please do let us know if you have any questions about this change.

By Barry Hughes

Enjoys all aspects of the software business. Also likes fresh air.

One reply on “Requirements Change for Action Scheduler”

Comments are closed.